Pages

jueves, 4 de abril de 2013

Porcentaje numeros pares e impares - Diagrama de Flujo

Realizar el diagrama de flujo de un algoritmo que lea N números e imprima el porcentaje de números pares e impares.

Pseudocódigo
Proceso PorcentajeNumeros
Escribir "Ingrese la cantidad de numeros:";
Leer cant;
par <-0;
Para i<-1 Hasta cant Con Paso 1 Hacer
Escribir "Ingrese el numero ", i, " :";
Leer num;
Si num%2 = 0 Entonces
par <- par + 1;
FinSi
FinPara
porcentaje <- par/cant*100.0;
Escribir "El porcentaje de : ";
Escribir " - numeros pares: ", porcentaje;
Escribir " - numeros impares: ", 100 - porcentaje;
FinProceso

0 comentarios:

Publicar un comentario en la entrada