Pages

jueves, 3 de enero de 2013

Calcular el cociente y el residuo sin dividir – Diagrama de flujo

Problema
Diseñar un algoritmo que permita, dado a, b determinar el valor de la división entera  y el resto de la división  entera de a, b (sin usar los operadores de div. Ni de Mod).

Solución

  • Entrada: 17 3
  • Salida: cociente 5 residuo 2
Se inicializa la variable “p” en 1 y la variable “q” en cero, se solicita ingresar dos números, se captura los valores en las variables “D” y “div”, luego
Se compara si el divisor es mayor igual al dividendo (D >= div)
Si es Falso (No)
    Se pide que ingrese un denominador que sea menor al numerador
Si es Verdadero (Si)
    Se crea un ciclo While, el cual termina si el cociente es mayor al dividendo menos el divisor, en cada iteración, se actualiza el valor de “q” con div*p , se actualiza el valor de ”p” sumándole 1, finaliza el ciclo, se muestra el cociente y el residuo. Fin.


Diagrama de flujo - Calcular el cociente y el residuo sin dividir.

 Diagrama de Flujo en FreeDFD
 Código fuente en Java
 Código fuente en C++
 Código fuente en C
 Código fuente en C#
 Código fuente en Python
 Código fuente en Visual Basic

2 comentarios:

Racing dijo...

Trato de hacerlo en Pseudocodigo pero me da error:

Proceso sin_titulo
p<-1
q<-0
Escribir 'Ingresa los dos numeros:';
Leer D,div;
Si D>=div Entonces
Repetir
MQ<-(D-div)>=q
Hasta Que q<-div*p o p<-p+1
Escribir 'El Resultado es: ' MQ;
Sino
Escribir 'Ingrese un Denominador menor que el numerador';
Fin Si
FinProceso

David Borja dijo...

Gracias, me has salvado porque yo pensé que DFD tenia la función para sacar eso

Publicar un comentario en la entrada