Pages

miércoles, 26 de diciembre de 2012

Calcular los n primeros números primos – Diagrama de Flujo

Problema
Calcular los n primeros números primos.

Solución
Ingresamos un número decimal donde se indica la cantidad de números primos que se desea obtener

Ejemplo
  • Entrada: 5
  • Salida: 2 3 5 7 11
Creamos un “objeto de entrada” para capturar la cantidad de números primos que se desea mostrar dicho valor se captura en la variable “num” .
Comparamos si num es mayor a dos (num>2)
Si es Falso (No)
    Comparamos si num es mayor a cero (num>0)
    Si es Falso (No)
        Muestra un mensaje solicitando ingresar un numero positivo o mayor a cero
    Si es Verdadero (Si)
Comparamos si num es igual a 1 (num=1) esto nos indica que solo queremos el primer número primo
Si es Verdadero (Si)
Nos muestra el primer número primo que es 2
Si es Falso (No)
Mostrara los dos primeros números primos 2 y 3



Si es Verdadero (Si)
Mostramos como salida 2 y 3 que son los primeros números primos
Luego inicializamos la variable con en 2 y n en 4, creamos un While con condición cont < num esto nos permitirá recorrer los números del 3 hasta el numero ingresado.
Inicializamos i con 2, creamos otro ciclo while con condición i<=n, el propósito del while aquí verificamos  si el numero va ser primo o no.
Verificamos si i es igual n (i=n)  
     Si es Falso (No)   
Verificamos si n MOD i = 0 nos permite determinar si  i es divisor de n
    Si es Verdadero (Si)
    Asignamos a i el valor de n para salir del ciclo
    Si es Falso (No)
    Salimos del ciclo
Si es Verdadero (Si)
    El número es primo y se muestra en la salida
    Actualizamos el contador sumando 1
    Salimos del ciclo incrementado el valor de i en 1
Salimos del ciclo incrementando el valor de n en 1



9 comentarios:

Anónimo dijo...

Escribir los primeros 100 números primos?

dany dijo...

Me podrias explicar un poco mas detenidamente como funciona?? tengo previa sobre esto el lunes y la verdad no entiendo muy bien. Gracias

Anónimo dijo...

no sabes cuanto te agradesco quien sea que aya hecho esto se merse todo y una vida increible q dios te recuerde por siempre

Anónimo dijo...

El programa jala pero no ejecuta que pedo?

Anónimo dijo...

eres un capullo tio te explicas como el culo
ya podias a ver puesto el programa en pascal y dejarte de tonterias
un saludo de tu amigo y vecino SPIDERMAN

sorda Robersy Cedeño dijo...

el programa que imprima los número primos del 1-200???

Anónimo dijo...

los numeros primos del 1 al 100 me podrias ayudar esq no entiendo muy bien

Unknown dijo...

Hola!! necesito que me ayuden con un programa en donde al ingresar 10 numeros me imprima el promedio de pares, la cantidad de primos,cantidad de numeros mayores a 50 y cantidad de numeros entre 10 y 50....porfisss es urgente!!

Juan José Galaviz dijo...

hola en pseint como hago para que dentro del siguiente código se omita el numero 7 y me muestre los demas numeros

Proceso Primos
Escribir "Ingrese la cantidad de numeros primos a mostrar:"
Leer cant_a_mostrar

Escribir "1: 2" // el primer primo es 2, los otros son todos impares...
cant_mostrados <- 1
n<-3 // ...a partir de 3

Mientras cant_mostrados<cant_a_mostrar Hacer

es_primo <- Verdadero // pienso que es primo hasta que encuentre con que dividirlo

Para i<-3 hasta rc(n) con paso 2 Hacer // ya sabemos que es impar
Si n MOD i = 0 entonces // si la division da exacta...
es_primo <- Falso // ...ya no es primo
FinSi
FinPara

Si es_primo Entonces
cant_mostrados <- cant_mostrados + 1
Escribir cant_mostrados, ": ",n
FinSi

n <- n + 2


FinMientras

FinProceso

Publicar un comentario en la entrada