Pages

jueves, 27 de diciembre de 2012

Sumatoria de números múltiplos de cinco – Diagrama de Flujo

Problema
Desarrolle un algoritmo que realice la sumatoria de los números enteros múltiplos de 5, comprendidos entre el 1 y el 100, es decir, 5 + 10 + 15 +…. + 100.
El programa deberá imprimir los números en cuestión y finalmente su sumatoria.

Solución
Inicializamos  la variable Sum en cero, luego creamos un ciclo For con la variable i inicializada en  5 y el ciclo continuara hasta que i sea menor igual 100,  el incremento de i es de cinco en cinco, luego Actualizamos el valor de Sum, agregándole el valor de i, mostramos los valores de i, finalizamos el ciclo y se muestra la suma total de los múltiplos de cinco.

   
Diagrama de flujo - sumatoria de múltiplos de cinco


 Diagrama Fuente DFD

Código fuente en Java

Código fuente en C++

Código fuente en C

Código fuente en C#

Código fuente en Python
Código fuente en Visual Basic


2 comentarios:

Anónimo dijo...

¿como se haria en pseint?

Anónimo dijo...

Algoritmo sin_titulo
cont<-0;
Escribir "ingrese n: "
Leer n
Para i<-5 Hasta n Con Paso 5 Hacer
cont<-cont+i
Fin Para
Escribir "la suma es ",cont
FinAlgoritmo

Publicar un comentario en la entrada