Pages

lunes, 31 de diciembre de 2012

Determinar si forma un triangulo – Diagrama de flujo

Problema
Hacer un programa o algoritmo que dadas tres longitudes, decir mediante un mensaje si forma un triángulo o no (cada lado tiene que ser menor que de las otras dos).


Solución
  • Entrada: 3  4  5
  • Salida: Si forma un triangulo
Se solicita al usuario ingrese tres longitudes de lados, estos valores se capturan en las variables “a”, ”b” y “c”, luego
Se compara si cumple con la propiedad de la desigualdad triangular ((abs(a-c) < b)  AND (b < (a+c)))
Si es Verdadero (Si)
    Se muestra si forma un triangulo
Si es Falso (No)
    Se muestra que no forma un triangulo
Finaliza.


Diagrama de flujo - Determinar si forma un triangulo

 Diagrama Fuente en FreeDFD 
 Código fuente en Java
 Código fuente en C++
 Código fuente en C
 Código fuente en C#
 Código fuente en Python
 Código fuente en Visual Basic

3 comentarios:

guadalupe lugo dijo...

si lo quiero hacer para que me diga que tipo de triangulo es (equilatero, escaleno, isoceles)
como se hace?

Crimson MT dijo...

Algoritmo sin_titulo
Escribir 'introduce 1 lado'
Leer a
Escribir 'introduce 2 lado'
Leer b
Escribir 'introduce 3 lado'
Leer c
Si a=0 Entonces
Escribir 'error'
Sino
Si b=0 Entonces
Escribir 'error'
Sino
Si c=0 Entonces
Escribir 'error'
FinSi
FinSi
FinSi
Si a=b Entonces
Si b=c Entonces
Escribir 'equilatero'
Sino
Escribir 'isosceles'
FinSi
Sino
Si a>b Entonces
Si b=c Entonces
Escribir 'isosceles'
Sino
Escribir 'escaleno'
FinSi
Sino
Si a<b Entonces
Si b=c Entonces
Escribir 'isosceles'
Sino
Escribir 'escaleno'
FinSi
Sino
Si b<c Entonces
Escribir 'escaleno'
Sino
Escribir 'escaleno'
FinSi
FinSi
FinSi
FinSi
FinAlgoritmo

Gustavo Ramos dijo...


#include
using namespace std;


int main() {
int a;
int b;
int c;
cout << "introduce 1 lado" << endl;
cin >> a;
cout << "introduce 2 lado" << endl;
cin >> b;
cout << "introduce 3 lado" << endl;
cin >> c;
if (a==0) {
cout << "error" << endl;
} else {
if (b==0) {
cout << "error" << endl;
} else {
if (c==0) {
cout << "error" << endl;
}
}
}
if (a==b) {
if (b==c) {
cout << "equilatero" << endl;
} else {
cout << "isosceles" << endl;
}
} else {
if (a>b) {
if (b==c) {
cout << "isosceles" << endl;
} else {
cout << "escaleno" << endl;
}
} else {
if (a<b) {
if (b==c) {
cout << "isosceles" << endl;
} else {
cout << "escaleno" << endl;
}
} else {
if (b<c) {
cout << "escaleno" << endl;
} else {
cout << "escaleno" << endl;
}
}
}
}
return 0;
}


Publicar un comentario