Pages

lunes, 31 de diciembre de 2012

Determinar si forma un triangulo – Diagrama de flujo

Problema
Hacer un programa o algoritmo que dadas tres longitudes, decir mediante un mensaje si forma un triángulo o no (cada lado tiene que ser menor que de las otras dos).


Solución
  • Entrada: 3  4  5
  • Salida: Si forma un triangulo
Se solicita al usuario ingrese tres longitudes de lados, estos valores se capturan en las variables “a”, ”b” y “c”, luego
Se compara si cumple con la propiedad de la desigualdad triangular ((abs(a-c) < b)  AND (b < (a+c)))
Si es Verdadero (Si)
    Se muestra si forma un triangulo
Si es Falso (No)
    Se muestra que no forma un triangulo
Finaliza.


Diagrama de flujo - Determinar si forma un triangulo

 Diagrama Fuente en FreeDFD 
 Código fuente en Java
 Código fuente en C++
 Código fuente en C
 Código fuente en C#
 Código fuente en Python
 Código fuente en Visual Basic

2 comentarios:

guadalupe lugo dijo...

si lo quiero hacer para que me diga que tipo de triangulo es (equilatero, escaleno, isoceles)
como se hace?

Crimson MT dijo...

Algoritmo sin_titulo
Escribir 'introduce 1 lado'
Leer a
Escribir 'introduce 2 lado'
Leer b
Escribir 'introduce 3 lado'
Leer c
Si a=0 Entonces
Escribir 'error'
Sino
Si b=0 Entonces
Escribir 'error'
Sino
Si c=0 Entonces
Escribir 'error'
FinSi
FinSi
FinSi
Si a=b Entonces
Si b=c Entonces
Escribir 'equilatero'
Sino
Escribir 'isosceles'
FinSi
Sino
Si a>b Entonces
Si b=c Entonces
Escribir 'isosceles'
Sino
Escribir 'escaleno'
FinSi
Sino
Si a<b Entonces
Si b=c Entonces
Escribir 'isosceles'
Sino
Escribir 'escaleno'
FinSi
Sino
Si b<c Entonces
Escribir 'escaleno'
Sino
Escribir 'escaleno'
FinSi
FinSi
FinSi
FinSi
FinAlgoritmo

Publicar un comentario en la entrada