Pages

viernes, 8 de marzo de 2013

Elevar un numero a una potencia - Diagrama de Flujo

Realizar el diagrama de flujo de un programa que permita  elevar un numero entero ingresado por teclado, a una potencia dada.

PSEUDOCÓDIGO
Proceso ElevarPotencia
Escribir "Ingrese un numero: ";
Leer num;
Escribir "Ingrese la potencia: ";
Leer pot;
rpta <- num;
Mientras pot>1 Hacer
rpta <- rpta * num;
pot <- pot - 1;
FinMientras
Escribir "El resultado es: ", rpta ;
FinProceso

15 comentarios:

Hugo 3 A dijo...

que significa rpta

Anónimo dijo...

para qué es rpta ?

Anónimo dijo...

rpta creo q es respuesta

Anónimo dijo...

par de idiotas

Eme lisenok volka dijo...

uhmm,pero, y si yo quiero elevar un numero a cero o a un numero negativo o elevar a una fraccion
este algoritmo no serviria
tengo el algoritmo que pasa si yo le pongo 2*0 ??

Anónimo dijo...

Amo a Aaron Samuels de Mean Girls

Anónimo dijo...

naa este ejercicio no me convence

Anónimo dijo...

payaso

Anónimo dijo...

:)

Anónimo dijo...

.-.

ozmar dijo...

no funciona para una base cuyo exponente sea cero, modificado quedaria asi

Proceso potencia
Escribir "Ingrese un numero: ";
Leer num;
Escribir "Ingrese la potencia: ";
Leer pot;
Si pot=0 Entonces
Escribir "El resultado es: 1" ;
Sino
rpta <- num;
Mientras pot>1 Hacer
rpta <- rpta * num;
pot <- pot - 1;
FinMientras
Escribir "El resultado es: ", rpta ;
FinSi

Fin Proceso

ozmar dijo...

Para cualquier potencia

Proceso potencia
Escribir "Ingrese un numero: ";
Leer num;
Escribir "Ingrese la potencia: ";
Leer pot;
Si pot=0 Entonces
Escribir "El resultado es: 1" ;
Sino
Si pot < 0 Entonces
pot<-abs(pot);
rpta <- num;
Mientras pot>1 Hacer
rpta <- rpta * num;
pot <- pot - 1;
FinMientras
Escribir rpta;
rpta<-1/rpta;
Escribir "El resultado es: ", rpta ;
Sino
rpta <- num;
Mientras pot>1 Hacer
rpta <- rpta * num;
pot <- pot - 1;
FinMientras
Escribir "El resultado es: ", rpta ;
FinSi
FinSi
Fin Proceso

Anónimo dijo...

SI YO QUIERO HACER UN PROCESO EN EL CUAL MI RESULTADO SEA Y=X^3/4 COMO QUEDARIA?

Aaron Raudales dijo...

Que Significa abs?

Anónimo dijo...

como










ayudaa!!

necesito hacer un algoritmo en PseInt de un binomio al cuadrado y un trinomio cuadrado perfecto

Publicar un comentario en la entrada