Pages

lunes, 18 de marzo de 2013

Media de las notas de un estudiante - Diagrama de Flujo - Código en C++

Cuatro enteros entre 0 y 100 representan las puntuaciones de un estudiante de un curso de informática. Escribir un programa para encontrar la media de estas puntuaciones y visualizar una tabla de notas de acuerdo al siguiente cuadro:

MEDIA PUNTUACION
90-100 A
80-89 B
70-79 C
60-69 D

• Realizar análisis
• Realizar diagrama de flujo de datos
• Elaborar el programa en C++

Diagrama de Flujo

Pseudocódigo

Proceso MediaNotas
//cantidad de notas
n <- 4;
nota <- 0;
// se declara un arreglo de n elementos
Dimension notas[n];
//se llena las notas en el arreglo
Para i<-0 Hasta n-1 Con Paso 1 Hacer
Escribir "Ingrese nota ",i+1;
Leer notas[i];
//comprobamos que la nota ingresada sea correcta
Si  notas[i]>= 0 Y notas[i]<=100 Entonces
Escribir "Nota OK";
Sino
Escribir "Nota incorrecta ";
i <- i-1;
FinSi
FinPara
//se calcula la media
Para i<-0 Hasta n-1 Con Paso 1 Hacer
nota <- nota + notas[i];
FinPara
nota <- nota/n;
//imprimimos el resultado
Escribir "MEDIA PUNTUACION";
//se busca equivalencia en la tabla
Si nota>=60 Y nota<=69  Entonces
Escribir nota,"        D";
FinSi
Si nota>=70 Y nota<=79  Entonces
Escribir nota,"        C";
FinSi
Si nota>=80 Y nota<=89  Entonces
Escribir nota,"        B";
FinSi
Si nota>=90 Y nota<=100  Entonces
Escribir nota,"        A";
FinSi
FinProceso



Código Fuente en C++
#include<iostream>
using namespace std;

int main() {

	float i;
	float n;
	float nota;
	float notas;

	n=4;
	nota=0;
	for (i=0;i<=n-1;i++) {
		cout<<"Ingrese nota "<<i+1<<endl;
		cin>>notas[i];
		if (notas[i]>=0&&notas[i]<=100) {
			cout<<"Nota OK"<<endl;
		} else {
			cout<<"Nota incorrecta "<<endl;
			i=i-1;
		}
	}
	for (i=0;i<=n-1;i++) {
		nota=nota+notas[i];
	}
	nota=nota/n;
	cout<<"MEDIA  PUNTUACION"<<endl;
	if (nota>=60&&nota<=69) {
		cout<<nota<<"        D"<<endl;
	}
	if (nota>=70&&nota<=79) {
		cout<<nota<<"        C"<<endl;
	}
	if (nota>=80&&nota<=89) {
		cout<<nota<<"        B"<<endl;
	}
	if (nota>=90&&nota<=100) {
		cout<<nota<<"        A"<<endl;
	}

	return 0;

}

0 comentarios:

Publicar un comentario en la entrada