Pages

viernes, 1 de febrero de 2013

Determinar los días que tiene cada mes Codigo en Visual Basic - VB

Problema
Diseñar un algoritmo que permita ingresar el número del mes y determinar cuántos días tiene el mes, para el caso de Febrero, el algoritmo deberá indicar que no cuenta con la información necesaria para dar la respuesta.

Solución
  • Entrada: 12
  • Salida: tiene 31 días
Codigo Fuente en Visual Basic
Public Class Form1
    Private Sub Button1_Click(ByVal sender As System.Object,
    ByVal e As System.EventArgs) Handles Button1.Click
        Dim m As Integer
        m = TextBox1.Text
        If (m >= 3 And m <= 12 Or m = 1) Then
            If (m <= 7) Then
                If (m Mod 2 = 0) Then
                    TextBox2.Text = "el mes " + Trim(m) + " tiene 30 dias"
                Else
                    TextBox2.Text = "el mes " + Trim(m) + " tiene 31 dias"
                End If
            Else
                If (m Mod 2 = 0) Then
                    TextBox2.Text = "el mes " + Trim(m) + " tiene 31 dias"
                Else
                    TextBox2.Text = "el mes " + Trim(m) + " tiene 30 dias"
                End If
            End If
        Else
            TextBox2.Text = "No hay informacion necesaria"
        End If
    End Sub
End Class

1 comentarios:

Alejandro Caro dijo...

En PseInt
Proceso Forma1
Definir m Como Entero;
Leer m;
Si m >= 3 & m <= 12 | m = 1 Entonces
Si m <= 7 Entonces
Si m % 2 = 0 Entonces
Escribir "el mes ", m, " tiene 30 dias";
Sino
Escribir "el mes ", m, " tiene 31 dias";
FinSi
Sino
Si m % 2 = 0 Entonces
Escribir "el mes ", m, " tiene 31 días";
Sino
Escribir "el mes ", m, " tiene 30 dias";
FinSi
FinSi
Sino
Escribir "No hay informacion necesaria";
FinSi
FinProceso

Publicar un comentario en la entrada