Pages

miércoles, 27 de febrero de 2013

Programa que apartir de una temperatura en grados Celcius determina si hace frío o calor - Diagrama de flujo

Desarrollar el pseudocodigo y diagrama de flujo de un programa que lea una  temperatura en grados Centígrados  y que imprima si hace frío o calor según el siguiente esquema: el clima es muy frío (temperatura menor a 0ºC), es frío (temperatura entre 0 y 9º C), es templado (temperatura entre 10 y 19ºC), es cálido (temperatura entre 20 - 26ºC) y muy caliente (temperatura mayor a 26ºC).


PSEUDOCÓDIGO
Proceso TemperaturaAmbiente
Escribir "Ingrese una temperatura";
Leer temp;
Si (temp < 0) Entonces
Escribir "El clima es muy frio";
Sino
Si (temp < 10) Entonces
Escribir "El clima es frio";
Sino
Si (temp < 20) Entonces
Escribir "El clima es templado";
Sino
Si (temp < 27) Entonces
Escribir "El clima es calido";
Sino
Escribir "El clima es muy caliente";
FinSi
FinSi
FinSi
FinSi

FinProceso


0 comentarios:

Publicar un comentario en la entrada